Scheduled Maintenance - Saturday, September 29, 2018 - 7:00 AM EST
Incident Report for CentralReach
Resolved
Maintenance has been completed. If you experience issues with user interfaces not completely loading, you may need to clear your web browser's cache. If you are experiencing any issues where some modules aren't loading - please be sure to check this help article for how to clear your browser's cache: http://help.centralreach.com/?p=12602
Posted 4 months ago. Sep 29, 2018 - 08:27 EDT
Investigating
We will be conducting routine maintenance to the application on Saturday, September 29, 2018 starting at 7:00 AM EST. While we expect no interruptions to service during the maintenance window, please be aware that system performance and accessibility may be affected. We expect the maintenance window to last no more than 60 minutes.

The update we are applying may require you to clear your web browser's cache. If you are experiencing any issues where some modules aren't loading - please be sure to check this help article for how to clear your browser's cache: http://help.centralreach.com/?p=12602
Posted 4 months ago. Sep 29, 2018 - 06:59 EDT