Blank Invoices
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Apr 18, 2018 - 15:39 EDT
Investigating
We are receiving reports that in some instances, invoices are downloading as blank documents. We are investigating the issue and will update the status as soon as we have an update to share.
Posted Apr 18, 2018 - 13:24 EDT