Issues with Checkboxes in Some Notes
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 11 days ago. Jan 11, 2018 - 14:13 EST
Investigating
We are currently investigating this issue.
Posted 11 days ago. Jan 11, 2018 - 12:41 EST