Issue with Appointments
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 4 months ago. Sep 20, 2018 - 14:36 EDT
Investigating
We’re aware of an issue with appointments, we understand the issue, and it should be resolved shortly. We apologize for the inconvenience.
Posted 4 months ago. Sep 20, 2018 - 14:26 EDT
This incident affected: Members Site (Web Site).