Notes with required Signatures Temporarily not saving
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Nov 09, 2017 - 10:49 EST
Identified
We've identified and are fixing an issue with notes and required signatures not saving at the moment. We expect to have this issue resolved very quickly.
Posted Nov 09, 2017 - 10:34 EST