Routine Site Maintenance
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 29, 2018 - 10:03 EDT
Monitoring
Please note that we will be performing a site maintenance Friday, June 29 at 7am EDT. While we do not anticipate any downtime, it is possible that you may experience some latency as the changes propagate through the system. Please check out our release notes for all of the details of our June Release: http://help.centralreach.com/?page_id=7140
Posted 6 months ago. Jun 28, 2018 - 12:55 EDT