Notes and Forms Saving Issues
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 04, 2018 - 11:51 EDT
Identified
We've identified the root cause of the issues with Notes and other various files. Please rest assured that no data has been lost. It may take some time for them to appear. We are working to resolve the issue and will post an update as soon as we have one.
Posted 3 months ago. Jun 04, 2018 - 10:23 EDT
Investigating
We are receiving reports of Notes not appearing after being saved. We are investigating the issue and will report back as soon as we have an update.
Posted 3 months ago. Jun 04, 2018 - 09:57 EDT