Platform Latency
Incident Report for CentralReach
Resolved
We are happy to report that the latency that was detected has been resolved.
Posted May 17, 2021 - 16:31 EDT
Identified
We are currently experiencing system latency across the CentralReach platform. Users may experience degraded performance.
Posted May 17, 2021 - 16:27 EDT
This incident affected: CentralReach Platform.