Platform Latency Detected
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 12:43 EST
Identified
We are currently experiencing system latency across the CentralReach platform. Our team is investigating and actively working to resolve this incident as soon as possible.
Posted Nov 07, 2019 - 12:28 EST
This incident affected: CentralReach Platform.