CentralReach Platform Latency Detected
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted May 04, 2021 - 15:37 EDT
Investigating
We are currently experiencing system latency across the CentralReach platform. Users may experience degraded performance. Our team is aware and investigating. We apologize for the inconvenience.
Posted May 04, 2021 - 15:15 EDT
This incident affected: CentralReach Platform.