Latency Detected
Incident Report for CentralReach
Resolved
The system is now fully operational and users are now able to log in and navigate as expected.
Posted Mar 01, 2021 - 17:26 EST
Investigating
We are continuing to investigate and are rapidly working on a fix to resolve the latency.
Posted Mar 01, 2021 - 05:00 EST
This incident affected: CentralReach Platform.