Latency
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 08, 2019 - 15:02 EDT
Identified
We are currently experiencing system latency across the CentralReach platform. Our team is investigating and actively working to resolve this incident as soon as possible.
Posted 3 months ago. Jul 08, 2019 - 14:46 EDT
This incident affected: Platform.