Scheduled Maintenance
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 13, 2018 - 08:13 EDT
Monitoring
We will be conducting a platform maintenance on Saturday, October 13th starting at 7:00 AM EST. While we don't expect any service interruption, please be aware that system performance and accessibility may be affected. We expect the maintenance window to last no more than 60 minutes.
Posted 5 months ago. Oct 12, 2018 - 16:17 EDT
This incident affected: Platform.