System Latency
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 06, 2019 - 13:30 EDT
Identified
We are currently experiencing system latency across the CentralReach platform. Our team is investigating and actively working to resolve this incident as soon as possible.
Posted about 1 month ago. Sep 06, 2019 - 13:05 EDT
This incident affected: Platform.