Platform Latency
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 23, 2019 - 11:50 EDT
Investigating
We are currently experiencing system latency across the CentralReach platform. Our team is investigating and actively working to resolve this incident as soon as possible.
Posted about 2 months ago. Aug 23, 2019 - 11:25 EDT
This incident affected: Platform.