Third-Party Change Healthcare Network Disruption
Incident Report for CentralReach
Monitoring
Change Healthcare has made progress in their restoration process. We have performed security and operational checks to confirm that we have the technical ability to safely submit claims and retrieve ERAs with Change Healthcare and have begun re-enabling this connectivity. Users should be aware that Change Healthcare has not yet fully reconnected with all payors and ConnectCenter is not yet available.

If your organization opted to use a temporary Office Ally connection to submit claims, we recommend that you continue to use that option until ConnectCenter is available and all of your payors are reconnected. The full list of Change Healthcare Exchange Payors for claim submission and ERA retrieval is available at https://support.changehealthcare.com/customer-resources/payer-lists

The CentralReach platform remains fully operational.
Posted Apr 12, 2024 - 11:03 EDT
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

Change Healthcare has begun reconnecting with payors, and is in a testing phase for their claims submissions process. We do not yet have clear timelines for the completion of their restoration efforts.

The CentralReach platform is fully operational.
Posted Mar 26, 2024 - 17:43 EDT
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions remain paused at this time.

The CentralReach platform is fully operational.
Posted Mar 18, 2024 - 12:17 EDT
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions remain paused at this time.

The CentralReach platform is fully operational.
Posted Mar 11, 2024 - 10:06 EDT
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Mar 04, 2024 - 08:59 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 29, 2024 - 08:55 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 28, 2024 - 09:10 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 27, 2024 - 10:26 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 26, 2024 - 14:36 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 26, 2024 - 09:00 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 23, 2024 - 16:15 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 23, 2024 - 09:20 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 22, 2024 - 16:46 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 22, 2024 - 13:26 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

If you are a Change Healthcare customer, Change Healthcare has advised that claim submissions be paused at this time.

The CentralReach platform is fully operational.
Posted Feb 22, 2024 - 10:49 EST
Update
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

The CentralReach platform is fully operational.
Posted Feb 22, 2024 - 10:10 EST
Identified
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

The CentralReach platform is fully operational.
Posted Feb 21, 2024 - 17:10 EST
Investigating
Change Healthcare is continuing to experience a service disruption and is working to resolve the issue. Monitor at status.changehealthcare.com.

The CentralReach platform is fully operational.
Posted Feb 21, 2024 - 10:24 EST
This incident affects: CentralReach Platform and Third-Party Services (Change Healthcare).