Change Healthcare Performance Issues
Incident Report for CentralReach
Resolved
Change Healthcare have restored and validated core services and continue to observe proper system functionality. You may experience some slowness throughout the day as services resume and absorb volume, and as Change Healthcare continues to re-optimize traffic.

If you sent claims yesterday, we strongly encourage that you audit for any error messages and check whether these claims are in Change Healthcare. If they are not in Change Healthcare's environment, resend the claim. Contact CentralReach Technical Support if you receive any further errors today. If the claims are present in the Change Healthcare environment, please be patient while they continue to process.
Posted Jun 09, 2023 - 11:37 EDT
Monitoring
Change Healthcare has restored and validated most of their core services, and expect that services will function properly at the start of business on Friday, June 9. Please be aware that you may experience some slowness with claims processing throughout the day as services resume. Change Healthcare and CentralReach will monitor throughout the day and weekend.
Posted Jun 09, 2023 - 07:25 EDT
Update
The Change Healthcare network and engineering team has isolated the problem of incoming traffic to a subset of our network and applications. They are working through specific actions to mitigate the issue.

With information currently available, please plan for access to be unavailable tomorrow (June 9). All vendors and appropriate teams are working on this with the highest priority.

The CentralReach platform and services remain otherwise fully operational.

More info at https://status.changehealthcare.com/
Posted Jun 08, 2023 - 22:36 EDT
Update
Change Healthcare is currently experiencing an outage impacting customer-facing applications that use Amazon Web Services (AWS) Cloud Services. Applications are experiencing intermittent connectivity, with customers unable to login. Engineering, application and vendor teams are working to restore connectivity, and an update will be provided when available.

The CentralReach platform and services remain otherwise fully operational.

You can find updates here as well as the Change Healthcare Status page: https://status.changehealthcare.com/
Posted Jun 08, 2023 - 17:01 EDT
Update
Change Healthcare is currently experiencing an outage impacting customer-facing applications that use Amazon Web Services (AWS) Cloud Services. Applications are experiencing intermittent connectivity, with customers unable to login. Engineering, application and vendor teams are working to restore connectivity, and an update will be provided when available.

The CentralReach platform and services remain otherwise fully operational.

You can find updates here as well as the Change Healthcare Status page: https://status.changehealthcare.com/
Posted Jun 08, 2023 - 17:00 EDT
Update
The Change Healthcare network and engineering team is continuing to troubleshoot the issue and monitor intermittent connectivity. There is not an ETA for resolution at this time.

The CentralReach platform and services remain otherwise fully operational.

More info at https://status.changehealthcare.com/
Posted Jun 08, 2023 - 16:11 EDT
Update
The Change Healthcare network and engineering team is continuing to troubleshoot the issue and monitor intermittent connectivity. There is not an ETA for resolution at this time.

The CentralReach platform and services remain otherwise fully operational.

More info at https://status.changehealthcare.com/
Posted Jun 08, 2023 - 14:28 EDT
Update
The Change Healthcare network and engineering team is continuing to troubleshoot the issue and monitor intermittent connectivity. There is not an ETA for resolution at this time.

The CentralReach platform and services remain otherwise fully operational.

More info at https://status.changehealthcare.com/
Posted Jun 08, 2023 - 11:26 EDT
Update
Change Healthcare is continuing to work on a fix for this issue. Currently network issues are significantly impacting the availability of several of Change Healthcare's applications.

The CentralReach platform and services are otherwise fully operational.

More info at https://status.changehealthcare.com/
Posted Jun 08, 2023 - 10:28 EDT
Identified
Claims processing vendor, Change Healthcare, is currently experiencing severe network issues that are significantly impacting application availability for several applications. Real-time processing and some batch processing is down. Change Healthcare engineering teams are working to restore service for these applications.

The CentralReach platform and services are otherwise fully operational.

Updates will be shared here, and more information is available at the Change Healthcare Status page: https://status.changehealthcare.com/
Posted Jun 08, 2023 - 09:59 EDT
This incident affected: Third-Party Services (Change Healthcare).