Platform Performance Issues

Incident Report for CentralReach

Resolved

CentralReach platform performance has returned to expected levels on the web and for CR Mobile.
Posted Feb 19, 2026 - 10:16 EST

Monitoring

The CentralReach platform performance has significantly improved, and we are continuing to monitor. We will provide more information as soon as it's available.
Posted Feb 19, 2026 - 09:58 EST

Investigating

We are aware of platform performance problems with the CentralReach system. Our team is actively investigating and working to resolve this incident as soon as possible. We apologize for the inconvenience. We will provide more information as soon as it's available.
Posted Feb 19, 2026 - 08:53 EST
This incident affected: CentralReach Platform.