AWS Outage
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Sep 02, 2019 - 07:05 EDT
Identified
Due to an Amazon Web Services outage, you may experience latency in the CentralReach platform. We will provide more information when available.
Posted Aug 31, 2019 - 14:42 EDT
This incident affected: Platform.