System Latency
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Sep 06, 2019 - 15:48 EDT
Identified
We are currently experiencing system latency across the CentralReach platform. Our team is investigating and actively working to resolve this incident as soon as possible.
Posted Sep 06, 2019 - 13:36 EDT
This incident affected: CentralReach Platform.