AWS Service Disruption
Incident Report for CentralReach
Resolved
AWS shared that their issue has cleared and all AWS systems are up and running at expected performance as of 6:47PM ET. CentralReach has performed additional testing on our platform and services, and confirmed that CentralReach is fully operating as expected, including the log in page. This incident is now resolved.

If you're experiencing any unexpected behavior at this time, we encourage you to submit a case with CentralReach Technical Support through the CR Community at community.centralreach.com or by phone at 800.939.5414 Option 2.
Posted Jun 13, 2023 - 19:09 EDT
Update
CentralReach is noticing improvements to our login page while AWS are reporting that their APIs are recovering. We expect that users will be able to log in to the CentralReach platform, however, please be aware that AWS is still monitoring services while they work toward full recovery,
Posted Jun 13, 2023 - 18:13 EDT
Monitoring
CentralReach is noticing improvements to the login page while AWS are reporting that their APIs are recovering. We expect that users will be able to log in to the CentralReach platform, however, please be aware that AWS is still monitoring services while they work toward full recovery, which may result in intermittent error messages or unexpected logouts.
Posted Jun 13, 2023 - 17:42 EDT
Update
CentralReach is noticing improvements to the login page while AWS are reporting a decrease in the elevated error rates that they were experiencing. While some users will be able to log in to the CentralReach platform, please be aware that AWS is still restoring and monitoring services while they work toward full recovery, which may result in intermittent error messages and forced logouts.
Posted Jun 13, 2023 - 16:55 EDT
Update
AWS are continuing to experience of elevated error rates that are impacting CentralReach. The Amazon Web Services teams are working on an urgent fix. The CentralReach login screen continues to be affected, but we will update our status page while efforts continue toward restoring access.
Posted Jun 13, 2023 - 16:21 EDT
Update
CentralReach is currently experiencing login issues due to AWS errors. Users currently logged in and utilizing the CentralReach platform are not affected. Be mindful of timeouts set in place by your organization to stay logged in and continue working. If you log out you will not be able to log back in until this incident is resolved.

In the meantime, AWS are continuing to experience of elevated error rates that are impacting CentralReach. The Amazon Web Services teams are working on an urgent fix. The CentralReach login screen continues to be affected, but we will update our status page while efforts continue toward restoring access.
Posted Jun 13, 2023 - 16:03 EDT
Update
AWS are continuing to experience of elevated error rates that are impacting CentralReach. The Amazon Web Services teams are working on an urgent fix. The CentralReach login screen continues to be affected, but we will update our status page while efforts continue toward restoring access.
Posted Jun 13, 2023 - 15:46 EDT
Identified
AWS have identified the cause of elevated error rates that are impacting CentralReach and are working on a fix. The CentralReach login screen continues to be affected, but we will update our status page while efforts continue toward restoring access.
Posted Jun 13, 2023 - 15:30 EDT
Investigating
We are experiencing a confirmed Amazon Web Services Outage which is affecting some software providers such as CentralReach. As a result, this is preventing users from logging in to the CentralReach platform. We apologize for the inconvenience, and we are working rapidly with AWS to restore access.
Posted Jun 13, 2023 - 15:05 EDT
This incident affected: CentralReach Platform.