Emergency Maintenance Window
Incident Report for CentralReach
Resolved
The CentralReach platform is now available.
Posted Jan 25, 2022 - 08:56 EST
Investigating
Emergency maintenance will be starting momentarily. Please save and logout, as our team will be working to fully restore performance. CentralReach will be unavailable during the maintenance period. We apologize for the inconvenience this causes.
Posted Jan 25, 2022 - 08:43 EST
This incident affected: CentralReach Platform.