Latency Issues
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 12, 2019 - 15:17 EST
Investigating
We have received reports of intermittent system latency issues, especially surrounding the Contacts and Permissions modules. Our team is investigating and actively working to resolve this incident as soon as possible. We apologize for the inconvenience this is causing.
Posted 7 months ago. Feb 12, 2019 - 15:01 EST
This incident affected: Platform.