Platform Latency
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Jun 24, 2019 - 14:00 EDT
Identified
We have identified an issue surrounding platform latency. Our team is working on a solution to resolve the issue and restore full performance.
Posted Jun 24, 2019 - 12:44 EDT
This incident affected: Platform.