Platform Performance Issues

Incident Report for CentralReach

Resolved

The platform is operating at expected levels.
Posted Sep 11, 2026 - 18:09 EDT

Monitoring

The platform is operating as expected--we're continuing to monitor closely.
Posted Sep 11, 2026 - 17:33 EDT

Investigating

We are aware that users are having trouble logging into and navigating the CentralReach system. Our team is actively investigating and working to resolve this as soon as possible. We apologize for the inconvenience. We will provide more information as soon as it's available.
Posted Sep 11, 2026 - 17:24 EDT
This incident affected: CentralReach Platform.