Platform Latency

Incident Report for CentralReach

Resolved

This incident has been resolved.
Posted Oct 30, 2019 - 15:19 EDT

Identified

We are currently experiencing system latency across the CentralReach platform. Our team is investigating and actively working to resolve this incident as soon as possible.
Posted Oct 30, 2019 - 14:51 EDT
This incident affected: CentralReach Platform.