Unable to Access Site
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 6 months ago. Sep 17, 2018 - 12:27 EDT
Investigating
We are aware that many customers are unable to access the site. We are working on resolving this issue.
Posted 6 months ago. Sep 17, 2018 - 12:00 EDT
This incident affected: Members Site (Web Site, Search, API), Hosting / Data Center (Servers, File / Resource Management, Site Access, DNS, Background Services), and Platform.