Authorizations Updates
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 11, 2018 - 10:49 EDT
Monitoring
The Authorizations screen in the Billing module is currently updating authorizations stats. This process may take several hours to be completed. We apologize for the inconvenience.
Posted 5 months ago. Oct 10, 2018 - 09:27 EDT
This incident affected: Platform.