Latency Issues
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 05, 2019 - 06:03 EST
Identified
We are currently experiencing system latency that may be affecting search results and our ability to display findings based on your search criteria. Our team is working on resolving this issue as soon as possible.
Posted 8 months ago. Feb 04, 2019 - 13:46 EST
This incident affected: Platform.