Service Disruption
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted May 24, 2023 - 12:21 EDT
Update
Platform performance is now operating as expected. Please reach out to our Technical Support team if you have any questions or concerns.
Posted May 24, 2023 - 12:15 EDT
Update
We've identified the source of a problem that is preventing users from logging in to CentralReach. We apologize for the inconvenience, and we are working rapidly to restore access.
Posted May 24, 2023 - 11:46 EDT
Investigating
We are currently investigating reports of a service disruption that is preventing users from logging in to CentralReach. We apologize for the inconvenience, and we are working rapidly to restore access.
Posted May 24, 2023 - 11:43 EDT
This incident affected: CentralReach Platform.