System Latency
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 19, 2019 - 17:27 EDT
Identified
We are investigating an issue surrounding latency across the CentralReach platform. Our teams are working to provide a solution as soon as possible.
Posted 7 months ago. Mar 19, 2019 - 14:40 EDT
This incident affected: Platform.