Office Ally Claim Processing Issues
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 16, 2019 - 13:40 EST
Investigating
We are currently investigating an issue affecting claims submissions to Office Ally. We are treating this as a high priority and will be providing updates as soon as possible.
Posted about 1 month ago. Jan 16, 2019 - 13:03 EST
This incident affected: Platform.