Slowness: Manage Connections in Contacts
Incident Report for CentralReach
Resolved
Manage Connections tool in Contacts, including bulk updates are now working as expected.
Posted Dec 28, 2023 - 20:25 EST
Investigating
We have detected slow response in the bulk connect/disconnect functions for the Manage Connections tool in Contacts. While our technical teams are actively working to improve this, please refrain from using this functionality at this this time.

All other areas of the CentralReach platform are currently operating as expected.
Posted Dec 28, 2023 - 18:08 EST
This incident affected: CentralReach Platform.