Platform Performance Issues
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 20:20 EDT
Monitoring
We have made improvements that have alleviated the log outs users were experiencing. We are continuing to monitor to ensure consistent performance.
Posted Apr 27, 2023 - 20:10 EDT
Investigating
We are investigating behavior causing log outs while using the CentralReach platform. Our team is actively working to resolve this incident as soon as possible. We apologize for the inconvenience. We will provide more information as soon as it's available.
Posted Apr 27, 2023 - 19:43 EDT
This incident affected: CentralReach Platform.