Site Latency
Incident Report for CentralReach
Resolved
The issue surrounding system latency has been resolved.
Posted Mar 26, 2019 - 07:17 EDT
Identified
We have identified the issue surrounding platform latency. Our team is working on a solution to resolve the issue and restore full performance.
Posted Mar 25, 2019 - 17:21 EDT
Investigating
We are investigating an issue surrounding latency across the CentralReach platform. Our teams are working to provide a solution as soon as possible.
Posted Mar 25, 2019 - 12:52 EDT
This incident affected: CentralReach Platform.