Maintenance Alert
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 16, 2019 - 17:39 EDT
Identified
A fix to address the issue surrounding signatures on timesheets is scheduled to be released today, April 16, from 5:30 to 6 PM EST. Users who are logged in during the maintenance window will be logged out. Please save all information and log out prior to the maintenance window. We apologize for the inconvenience.
Posted 6 months ago. Apr 16, 2019 - 16:37 EDT
This incident affected: Platform.