Platform Performance Slowness

Incident Report for CentralReach

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 14:01 EDT

Monitoring

The CentralReach platform has returned to expected operating levels. We're continuing to monitor performance out of an abundance of caution.
Posted Aug 13, 2026 - 13:22 EDT

Identified

We're making adjustments to improve user experience and responsiveness of the CentralReach platform. Our team is continues to investigate and are working to resolve this incident as soon as possible. We will provide more information as soon as it's available.
Posted Aug 13, 2026 - 13:05 EDT

Investigating

We are aware that users are experiencing slowness the CentralReach platform. Our team is actively investigating and working to resolve this incident as soon as possible. We apologize for the inconvenience. We will provide more information as soon as it's available.
Posted Aug 13, 2026 - 12:50 EDT
This incident affected: CentralReach Platform.