Elevated Site/API Errors
Incident Report for CentralReach
Resolved
This incident has been resolved.
Posted Mar 24, 2022 - 15:27 EDT
Investigating
We're experiencing an elevated level of API and/or Site errors that are impacting the customer experience. Our team is looking into the issue to resolve it as soon as possible. Please use caution and save frequently if you choose to log in.
Posted Mar 24, 2022 - 15:13 EDT
This incident affected: CentralReach Platform.